Forums » Elder Scrolls

Had any game-breaking glitches?

    • 29 posts
    November 27, 2011 10:55 PM EST

    I've had NO game-breaking glitches until today...  when I had two.  That certainly lowered my respect for the game, high as it may be.  I spent a VERY long time trying to fix them.  

    1. One Companions quest could not be completed because I had started another quest taking place in the same dungeon.  I eventually figured a workaround, although it will take a lot of my time, trying to get back all my lost progress.  

    2. NPCs are tripping and dying at my wedding!  "Just leave" is all I hear...


    Any advice?  Any similar stories?

    • 16 posts
    November 27, 2011 11:00 PM EST

    After I read a word on a word wall, like 10 dragons spawned and my xbox flipped out and had a panic attack.





    • 577 posts
    November 27, 2011 11:02 PM EST

    Yeah, I have and it sucks. I can't complete the Companions. It's stuck at when I get back from the Witche's Den and the dude (can't remember his name) is dead. Pissed me off for a bit. Didn't play for a while then said fuck it and continued on with the rest of the game and quests. Aela and another dude are still standing out front of Jorraska in a fighting stance. Seems I've tried everything. I have the guide and might just try and go to the next quest and see if it will "activate" or something. I've put waaaaayyy to many hours to start over, both before the incident an after.

    Sorry dude, but that wedding thing that's going on with you is pretty funny. Must be the Kool-Aid. Ha!!

    • 29 posts
    November 27, 2011 11:53 PM EST

    Yeah, just finish the Companions in another character in  the future.  The end isn't all that great.

    • 10 posts
    November 27, 2011 11:56 PM EST

    I had the same exact problem! maybe it will be fixed in the next patch.

    • 8 posts
    November 27, 2011 11:58 PM EST

    Spoiles: Uh, he is suppose to die. It's scripted. You complete it later (2 quests later) after you take out all the silver hands. You then attend his funeral and go cure his (and your, if you want) werewolfism (lyc-somethingoranother)

    • 2 posts
    November 28, 2011 12:13 AM EST

    the only thing that bothers me is that after an hour of playing the fps drop down to 3

    • 7 posts
    November 28, 2011 12:49 AM EST

    Yeah, the greatly increasing frame rate issue on the PS3 version.  lol

    • 10 posts
    November 28, 2011 2:04 AM EST
    I can't buy the windhelm house. Like many others I can't get blood on the ice to activate. And therefore can't buy the house.
    • 1 posts
    November 28, 2011 5:42 AM EST

    Got the game on PC. Can't even play the game because there's no sound and the game won't progress from the intro. Game breaking? Definitely. From the intro everything looks fine steady frame rates good textures and such. Had Skyrim since the midnight launch. Let's see if the patch will fix this.

  • November 28, 2011 6:37 AM EST



    the only one i've had, is during the main quest when attempting to get ulfrik to agree to the peace conference, and i happened to be joining the stormcloaks at the time, and the dialogue was broken because ulfrik sent me to his right hand man, and his right hand man sent me to ulfrik in an infinite loop. had to use console commands to fix. kinda lame.

    • 2 posts
    November 28, 2011 7:15 AM EST

    I've had mostly graphical issues lately, like trees turning pink and looking trough walls. (AND I really really doubt there is something wrong with my computers graphics card). Also dragons are bugged sometimes like they move very slowly when flying, which makes very easy targets. One dragon once disappeared when I killed him. And I've got those dragon skeletons jumping all over the place, I really wish they were gone after 3 days or something cuz we've had about 5 to 6 attacks on the college of winterhold. Dragons seem to like roasted mages for some reason

    But Im not saying theese glitches happen all the time, still I would be very pleased if this get fixed very soon

    • 708 posts
    November 28, 2011 7:21 AM EST

    I bought the house and then Blood on the Ice started when I went in for the first time?

    • 297 posts
    November 28, 2011 8:30 AM EST

    i had a glitch that wouldnt allow me finish alduins bain i was stuck in the cut-scene when you read the elderscroll and it wouldnt let me out

    i fixed this by typing a code into the tab menu it works and i finished the mq now hurray!!!

    • 1 posts
    November 28, 2011 8:48 AM EST

    my main quest is bugged cant complete it ;(

    • 7 posts
    November 28, 2011 8:55 AM EST
    Nothing too major but when I bring up my menu ANY of the menu's - i.e. favorites, ingame, and so forth - they tend to freeze up. I'm not sure if it's because I don't have the update but It can get annoying.
    • 577 posts
    November 28, 2011 9:20 AM EST

    Yeah I know he's suppose to die, but the next quest "purity revenge" or whatever it's call doesn't start up. I done everything, trust me. It's a glitch.

    I just want to finish it. Even if it's not that good. Stops all the radiant quest and everythng to do with the Companions. *tears* I was thinking of asking Aela to marry me...*sniffles*

    • 577 posts
    November 28, 2011 9:24 AM EST

    I haven't finish the main quest and I believe the civil war isn't the main quest. Dealing with Dragons is the main quest. The War is all on its own.

    • 10 posts
    November 28, 2011 9:26 AM EST
    Youre lucky!
    • 297 posts
    November 28, 2011 10:13 AM EST
    Whats bugged about it i may be able to help
    • 24 posts
    November 28, 2011 11:30 AM EST

    ---> SPOILER



    When I first tried to defeat Alduin, and casted a 'Dragonrend' on him, he stucked in the air in a sitting position shouting flames at me. As I shooted arrows on him, his health bar gone to zero but he didn't die. It was so weird, it killed the epicness a bit. I had to do that mission all over again.


    • 29 posts
    November 28, 2011 4:26 PM EST

    Update: My NPC trip-and-die glitch is about to be fixed, just have to wait until Wednesday!

    • 29 posts
    November 28, 2011 4:26 PM EST

    Same happened to me.  

    • 29 posts
    November 28, 2011 4:27 PM EST

    Thank Talos for the PC version!

    • 29 posts
    November 28, 2011 4:28 PM EST

    You can't really say anything about that if you haven't finished the main quest...  I have, and he's right...