Forums » Elder Scrolls

ESO Help

    • 5 posts
    April 15, 2017 5:53 PM EDT
    Good day everyone,

    I wanted to get back into ESO, and I am looking for some technical help. Since the latest patch, I have not been able to get past the ESO Loader. Every time I hit "play", I get an error that says "ESO has stopped working". I have tried all the suggested fixes on the Support page, but no luck. I am playing on PC, and was wondering if someone would know if there is a way to fix my current issue.

    Thank you!
    • 260 posts
    April 15, 2017 11:47 PM EDT

    Hmm. No error messages? If so, I'd recommend trying a reinstall. It sucks, to be sure, but if you've already tried the other stuff, it's the best advice I can give you.

    • 277 posts
    April 16, 2017 6:13 AM EDT
    Yeah, reinstall is what I'd also do in your shoes.
    • 5 posts
    April 16, 2017 10:28 AM EDT
    Thank you for the advice, but I found a resolution to my issue. After preforming a reinstall, repair, NVIDIA update, windows update, add on removal, and a few other things...I still had nothing.
    So, I decided to try one more thing. I uninstalled the Intel 4600 graphics, restarted my laptop, did a windows update, reinstalled the Intel 4600 Grafics, restarted again, and BOOM...ESO is working just fine. I'm no tech wizard or anything, so I am hoping I didn't do anything destructive to my computer.
    Once again thank you for your advice!
    • 260 posts
    April 16, 2017 10:30 AM EDT

    Wow. Sounds like quite the proccess! Glad everything worked out, though.